Battery life could be a major issue

As you know, many of us are having issues with numerous aspects of our sentinels. As I have mentioned in previous posts, I have my 16 deployed in several locations. One of the locations is my warehouse. Truck drivers are carrying them, I have them attached to forklifts and other materials handling equipment that moves around constantly. Some are crisscrossing the US in trucks right now. But obviously I have them all registered in the app and I know where most of them are in a general sense.
I decided to walk the warehouse today with the app fired up (there’s a bridge in the warehouse as well) and started trying to locate the 4 I knew for sure were there. The app located two of them no problem. But the other two, despite standing right next to them could not be found. That is until I pressed the button on them.
So I started thinking about what could cause a problem like that. Yes, I understand we are on beta firmware but still, why do some seem to work fine and others not so good?
Then it dawned on me! I wonder if the batteries are good. I work with a ton of wireless A/V equipment. Battery strength has a huge impact on the functionality of these devices. So much so, that we have a standing rule that all battery operated wireless devices get fresh batteries daily on show sites. So I decided to pop a few sentinels and check the batteries. I think my pic will be self-explanatory.

My guess is that these batteries were purchased in bulk sometime last year. XYO claims a 5 year battery life. I know there ain’t no such thing as a 5 year battery for any electronic device that broadcasts and receives RF. The more a device transmits and receives, the faster that battery is going to die.
So my advice to all of you is buy a cheap little battery checker like the one pictured and check your sentinel batteries. I went one step further and grabbed a VOM to see what the actual voltage was(they are 3V lithium) and wow, 1.8 volts! This battery is on its last legs!
The sentinels make at least 4 different sounds from my observations and one of them could be a low bat alert. But who knows? I can’t find anything about the meaning of the different alert sounds beyond the initial two it makes when registering them in the app. Check your kits folks and replace batteries that are below 2.5Vs.


I would love to know what the sounds mean and also do you have any tips.on how to change the battery?

1 Like

To change the battery you just use a coin in the slot on the side of the sentinel and carefully separate the two halves. Also be careful, the battery is not secured, it will fall out, so do it on a table top.
After messing with a few sentinels I’m pretty sure they make at least 4-5 different alert sounds. There is no information published yet that I can find that explains what each tone means.


Just to clarify a point or two about testing batteries. Load testing and resistive testing are obviously different things and will indicate different results. My cheapo battery tester does not give a completely accurate result. Nether does a simple Volt Ohm meter. You’ll find that one shows a week battery and the other measuring the same shows the battery to by fully charged. It’s much too deep to get into here, but the simplest way to state is thus; A battery can have a reduced capacity under a load, but test perfectly normal via DC resistance. My cheapo and my professional VOM use slightly different processes. THE BOTTOM LINE-batteries under a load (transmitting or broadcasting for instance or cranking your car engine) react differently and the process of calculating a battery’s ability to deliver a specified voltage under load is not the same as measuring it’s positive potential voltage with a resistive circuit. So, often the safe bet is to replace batteries the have a large disparity between the two types of test.Battery science is damn interesting.


All eight of my sentinels turn off after about 4-5min. They also register on the find it app as strong, but haven’t checked with a meter yet


By “turn off” I assume you mean that when you are looking at your monitor for the bridge interface, the number of found devices is incorrect. Same for my sentinels. But if I use the app, it has no problem finding them. My guess is that the app is pinging on the frequency they use and the bridge firmware that will do the same thing eventually is not and they will fix the problem. Remember, this is beta-testing going on right now.


Turning off meaning they cannot be located using the find it app on the phone. The shut off and will not communicate via Bluetooth. That part if the system should not be beta. Folks are getting upset trying to locate their items. I’ve lost one already because it shut off and it didn’t know it would.

1 Like

I read on the Telegram channel that it most likely isn’t a battery problem, but a software problem, which they are working to fix.

Dito… all 8 of mine turn off after just a few minutes of use. Less than a months worth of use and all of them are failing (my guess is battery failure). Kinda disappointing. Come on XY, this should have been tested prior to shipping. Perhaps you should offer to replace our sentinel batteries and guarantee at least a 6 month life span?


Sounds to me like the 5 year battery life span is false advertising. What is the law in America regarding false advertising? Is that a criminal charge or will it not be heard in till the shutdown is over( assuming I heard correctly that civil courts are closed due to the government shutdown)?

1 Like

Whoa now, there’s no criminal intent and I think everyone just needs to take a breath and hold tight for a few more weeks. If you aren’t on Reddit and paying attention to r/xyonetwork, you should be. I created a topic and pointed out many of the flaws in their approach and the massive fail they had are their hands concerning customer service etc. Scott replied to that topic and answered some questions and promised that a fix was coming in just a few weeks. They are aware of the problems and frustrations everyone has. My advice is don’t throw out the baby with the bath water. Buy some new batteries and when the firmware patch comes out replace the batts and update the seintels. If the product still doesn’t work, I think anyone and or everyone will be asking for refunds. But that would be a disaster for them and I’m pretty sure they understand that. Again, get on Reddit and join r/xyonetwork and make your voice heard. This forum is not the right place. If they don’t get their shit together soon, the Reddit community will make their lives hell.
Also a good point to remember; This isn’t a consumer gadget. It’s a whole new tech being built and those of us that bought Class A shares and are holding many thousands of XYO tokens have a vested interest in seeing/helping them succeed.


One can perform criminal acts without it being their intent. If I rush across a road to pull a child out of the way of a truck in america, my intentions are right, but it’s still jaywalking.

Different countrys have different rules, this is another aspect that they have not considered resulting in them violating British law by not providing instuctions in the kits and not safety testing them properly.

By British law definitions, the bridge is an electrical device, by British law the xy4+ is a consumer good or a toy. Different countries have different definitions as well. They need to get their minds into the laws of everywhere that they send the devices, some counties the law only comes in if it’s sent from a country. For England, Wales and Scotland and a lot of European countries the laws apply if the customer is in the coutry thd laws applies to even when buying from another country.

As for not posting here… This is their official “community” form, if they don’t want to have repusentation here they should delete the community.

I understand your frustration. Yet this kind of FUD is pointless and is really not germain to the forum. We don’t need lessons on consumer protection laws. We need to share info and data with each other to help identify and correct problems, bring them to the attention of the Dev team and work towards a mature network that benefits all.
Otherwise, contact support and ask for a refund.


I have my mining kit. Do I just plug it in and thats it after I sync my sentinels?

1 Like

You do not need to update sentinel firmware to build an origin chain. You are not providing any accurate info here George.

edginter - I would hook up a usb mouse - keyboard and HDMI monitor to your bridge, so you can set up wifi if you need to and see that the bridge is functioning, at least until you know its working. Have some sentinels within bluetooth range of the bridge and you will see them as nearby devices and start building an origin chain as long as the bridge can connect to the default archivist.


Hello fellow GeoHackers, I’m just putting up my post so I can be notified if any of you find out any info regarding the sentinels turning off. I have ran a gamut of testing to try to figure out the problem, using BLE testing equipment, the apps/bridges, and common cell devices and computers. I am having the exact same issue, especially after updating to the .56 firmware.

After updating to this firmware they are recognized as XY4++, instead of the XY4+ as they came shipped as. However, they indeed all shut off automatically after four minutes. I have ran a whole bunch of little experiments measuring battery power, load, etc. What I am coming to a conclusion is that is more a software issue than battery issue. I was able to order new batteries (wow CR3032 are expensive compared to others); and after installing new batteries, they still turned themselves off after about four minutes. I have tried connecting them to different bridges/phones, the actual XYO Bridge, and the Beta app on 4 different android devices, no change in outcome. On both the XY Findables APP and the Beta XYO Network App, and the Actual XYO Bridge they all can not be seen after they make their little beep tone and turn off. I also used an Ubertooth One and again no signal was available showing that they are in an Off state or dormant state.

I have a total of 16 sentinels, all are the XY4+ model, after moving 5 of them to the .56 firmware update, without doubt those shutdown after four minutes. However on the sentinels I left on .53 it was randomized, some would stay awake, some would turn off, all at random times, locations, etc.

I would love some feedback if any of you have had similar experiences or tests; the more the merrier. I am in no way angry at XYO, I understand the processes of building a new business/technology/device, and it can be very daunting to say the least. Am I disappointed, of course, I want to go out and mine, just like all of you do, but everything is still in Beta, lets give this some time and see where it goes. I am in no way an expert in BLE or XY devices, I’m actually a US Army soldier who is very interested/passionate in both tech and blockchain and what XYO is bringing to the table. Looking forward to your replies. I think I will also start my own separate post with this content so others have better visibility of it

1 Like

Great post RCL! I too am using the tech I have available to test. Specifically, I’m using the Shure Axient Spectrum Analyzer, a hardware device that interfaces with a networked laptop running Wireless Workbench that is used for wireless AV tech. I often deploy over 100 wireless devices at a large event and managing frequency allocation to avoid cross talk and dropouts is super important!
I now agree that battery strength is not the issue. The software that manages battery usage is definitely/probably part of the issue. The other thing I discovered is that the bridge is also not pinging on a regular basis. The bridge appears to stop pinging after approx 4-5 minutes as well. The Bluetooth in the bridge has an issue. Unfortunately we can’t log into the bridges as a “headless” device, even though it’s connected directly to a router. I think that is an issue that they will have to implement. If you have to setup a monitor/keyboard/mouse just to see if it’s functioning, that’s a fail. This is probably a security issue for them. Several people have tried modding their own rPI devices with software available on Github. To my knowledge nobody has had success. And this makes sense because I’m sure many users with Linux skills would try to fuck with settings. Although I can barely navigate linux, it seems clear that they could implement a user login that doesn’t have root. Hopefully they’ll take that into consideration.
It’s really great to hear from another user that isn’t focused on the downside as we’re in beta mode and is active in a positive and constructive dialog.

1 Like

Hey @ricthesoundguy , awesome reply as well, you actually made me look into the XYO Bridge a bit more, and I concur, it also stops pinging (even on the stable software) after a couple minutes. I have set it up with the keyboard and mouse and monitor and played around with everything. After it stops scanning for devices (it does have a timed discovery time, I have to measure it), in the Nearby Devices area it should be able to be brought back to a discovery state/reload. I see this is redone by just pulling down and holding for a second with your main mouse button, just as you would swipe down on a phone app. The circular reload symbol does come down and spin, however no hardware effect occurs. In all, if the Bridge (which also functions as its own sentinel) and the sentinels are powering off their BT in a set time, I think this could easily be fixed by a software update and I’m not stressing it as much as I was the first couple times it happened before I saw I was not alone in this. Also maybe there is some type of reply or connection the bridge or sentinels maybe looking for, along the lines of a BT handshake to keep them alive and when it does not receive this it defaults to a shutdown time to save battery, but I don’t put much stock in this because it would defeat the purpose of being able to place them in areas of network/device traffic, and they would need to stay active regardless of how long since it has been pinged.

So today was my day off and I have spent it trying to analyze these things, I haven’t really left the house much today. Saying that, I have got 6 “cha-chings” since this morning, meaning my XYO Dashboard is reporting I have 6 Origin blocks to my first chain. I don’t know how this compares to you or anyone else reading this. Would love to hear from anyone else, how high their Chain Lengths are, and how long they have been using them or traveling to different locations.

Back to the Bridge, I have mediocre Linux Command Line skills lol, but at this point do not feel like diving in to the bridge with that, as I feel I just don’t know enough about the software and don’t want to screw it up, cause I have read some nightmare stories already of others making the same attempt. Are you running on .53 or .56 firmware on your sentinels? Thanks for responding and hope others will chime in with any info they may have.


I managed to get mum to buy 2 sentinels for me in preparation for my next visit to my partner. Reminded her that it might be a good idea to be able to track me as I’m on medication that has a 1 in 10 chance of heart failure, if i’m kidnapped (she believes some of the rubish she hears 3rd hand about an areea she has never been to) it might be nice for her to be able to know last known location and it’s also nice for me to be able to find my bag at JFK. Anyway… I’d like to add my voice to those that are saying that they find their xy4+'s turning themselves off… this is not a problem that I found when I had 3 phones on sentinel (But did when I had 2 phones on sentinal). So I think it’s the bridges software as it’s effecting both my tablet and your pi’s (as I’m still using my tablet as my bridge).

Edit:I am using .56.

1 Like

I have a mediocre understanding of a couple of things.

  1. Your phone app while active is supposed to create “bound witnesses”, which from what I understand from the current info available means that your sentinels can/do exchange data.
  2. My bridges are growing their Origin Chain. My home bridge is at 1750+ and growing, albeit slowly despite many sentinels moving great distances constantly. My work bridge is at 679 and hasn’t changed in a month. I believe that is because I have poked a hole in my home firewall for the Archivist IP/port, but I am not able to do that at my workplace, so the Origin Chain is not growing-Most of that origin chain was driven by the first few weeks I had both bridges at home connected to my local network.
    All my sentinels are .56
    My bridges still show .07 Beta firmware, despite auto updates being enabled.
1 Like