Aristotle & Web App & New XYO App

#1

Hey Fellow Geohackers,

So looking for some feedback from everyone; I been messing around with Matrix, Web App, Network App, and other XYO greatness. First of all, I hope everyone is calm, the new XYO Network app is still in very much an Alpha/Beta phase. I’m sure we will get tons of messages on here of some users getting excited cause its not working for full potential yet. I just see it as great time to get familiar with the tech background of it, look around the Dev area, and mess with every nook and cranny in the Apps and Matrix. In this post I am going to mainly focus on the new Network App. So as you can see, you can’t add your bridge yet…and sentinels should be coming soon, but you can still start adding to your Cryptographic Bound Witness Chain right now. What you need is to download the new Network App on two separate Android devices, get your Sentinels back into Bound Witness mode, and then let them interact with the world around you.

1. Download the New XYO Network App from the Google Play store or install the .apk on both of your Android devices (ie. phone, tablet, Chromebook, unlocked Fire devices, etc). If you have trouble finding it, then just search for the COIN app, when that comes up in the search results, click on that. It will open up the description and from there, you can directly click on the Developer’s name, which is right underneath the title of COIN App at the top. It should be in blueish color and say “XY-The Persistent Company”. If you click that, it will show you all the Apps that are created by XY, and this can be done for all developers of all the apps in the Play Store(its a cool way to find lots of unreleased or beta versions of apps since they wont come up in normal searches).
2. Sign in to the new XYO Network App with your normal XYO account information(username/password) that you use on the COIN app and in the first XYO Network app, on both devices.
3. Those who were using COIN app with your Sentinels, this put your Sentinel in a “always On” mode, so that you could easily connect with your phone/tablet and GeoMine to grab up those awesome XYO tokens. However, when your Sentinels interact with your XYO Network App, they will go back into “turn off in 4 minutes” mode. Just double press the Sentinels button while your new XYO Network app is running on your phone to get it into this mode. Give your Sentinels a couple minutes to recognize the new app, and don’t be afraid to push the Sentinel buttons lots of times, you can’t harm them. Don’t worry, you can always switch right back to the “always ON” mode by just going back into your COIN app and clicking the button on your Sentinels when the COIN app is running (make sure to turn off/close the XYO Network App).
4. Now you should have both your Android devices running the new XYO Network App, be signed in to both with the same credentials and have your Sentinels in the vicinity.
5. If you have done this correctly, you should see your Cryptographic Bound Witness number at the top of the app start to increase in number. This is the same thing as the “Origin Chain Length” on the previous XYO Network App.
6. If your not seeing it jump up in number or refresh, just touch the Dashboard button on the bottom left corner in the XYO Network App (the one with the little house for a symbol). This should refresh your screen and you should see that number rise on both devices. The more signals/devices your Sentinels interact with, the quicker you will see this number rise.

Hopefully it looks something like this! I’m going to continue to mess around now in Matrix and then I will update this Post or make a new one on those elements, as well as the Web App which is very similar to the Android App.

P.S. If your using a newer browser after you go to the app.xyo.network site, if you click over to your options in your browser (the three little dots on the upper right in Chrome), you will see one of the options is the ability to Install a web app version right from there. Just look down the list and you should see a “Install XYO App” in your drop down. You can click that and add it to your desktop, or on a mobile device it will add a new cool looking purple XYO Icon, that when clicked bring you directly to the XYO Web App…Only now its in this badass looking purple overlay.

Send your feedback, questions and comments!
ReconCatLord :telescope::cat2::crown:

7 Likes
Is it spoofing? 2 devices with COIN?
Bridge Activity Since Web App release
No bound witnesses
Is it spoofing? 2 devices with COIN?
#2

Recon - I don’t believe the new XYO network app on android is seeing the sentinels yet. When you hit add new device it says firmware coming soon, and sentinels under my devices stays at 0. I think the cryptographic bound witness count is rising due to interactions between the 2 android devices at this point.

1 Like
#3

@Yompster I think you may be right, but the one thing I noticed was if you switch over to the Close Devices Tab, you should see your phone picking up BL connections/devices. Now my phones can view and connect to the XY4++ Sentinels directly in the Bluetooth menu and on the XY Find it App. So since the two phones acting as Bridges are seeing each other, I can’t see a reason why they shouldn’t be picking up the Sentinels. I have to pull out some of my gear and a laptop with a bunch of signal detection equipment. I have an Ubertooth One, and a pretty good SpecA that can identify the individual identifications of each Sentinel and try to match it up with the crazy long BLE address that shows up in the Close Devices menu. That way I can determine if the Phones(“bridges”) are seeing just other device connections or the actual Sentinels. They may not be able to be “added” in the Network App, but still might be seen, detected and passing info to up that CryptoGraphic Origin Chain. I will let you know tonight what I find, its freaking almost April and it snowing here in Kansas this morning and suppose to be 25 degrees tonight so I am staying in and just messing around with this stuff. Have you used the Matrix at all, that’s next on my list of tech to play with lol. Thanks for replying and feel free to Like and Share/Link my posts as much as possible so we can help as many Geohackers as we can.

ReconCatLord :telescope::cat2::crown:

1 Like
#4

I have been tinkering with the matrix, but even tho I have ETH and XYO in my metamask wallet, the network requests always chokes on the ETH in wallet part of the setup, so not sure what the issue is there.
I’ve also noticed the new XYO network android app seems to only add bound witness when the app is front and center, not when it is in the background. If that’s the case, it will need to be fixed. I haven’t proven that for sure tho.

1 Like
#5

image
change to test network and try again

2 Likes
#6

Thanks Top, that was the issue !

2 Likes
#7

:cowboy_hat_face: glad I could help,

not sure how exactly to make network request though…

:thinking:

1 Like
#8

I get the Bound Witness number to start to increase, but after about 10 seconds one or both of the XYO apps crash on the phone. Not sure it’s worth messing with too much until the new firmware is released and the sentinels can actually be added and claimed.

1 Like
#9

@_ryan What devices are you running the App on. I am running it on a Samsung Galaxy Note 9, Samsung Galaxy Note 8, and a Google Pixelbook Chromebook and I have had a very small number of crashes. But they pretty much stay on and active in the background with no issues. I would mess around as much as possible, whats the worst that can happen? You will get super familiar with the tech, and possibly could get a jump start on building your Origin chains for archivists. Yes it might be very redundant data, but hey, you never know when it might be queried one day in the future and pay you some XYO. Technically Bridges can act as their own Sentinels, so you can drive around or go about your day with both your devices running the XYO Network App in the background and should be the same as having a Sentinel connected to one of your devices acting as the bridge. Let me know what type of crash it is, do you get an error message? does it drop back to your home screen? or does the App lock up? Maybe I can help

ReconCatLord :telescope::cat2::crown:

#10

I’m using a Nexus 5 (wifi and cell) and a Moto G3 (wifi only), both running Android 6. The XYO Network app is completely stable for me until I get the two doing bound witnesses… that’s when the crashes started, dropping to the phone home screen. I will be getting a Moto G7 next month (Android 9) and then the Nexus 5 will become a third play thing. I plan on then taking the Nexus 5 up to Android 8 or 9 at that point (and replacing the battery that is shot).

I’m definitely playing around with everything I can, I’ve even pulled the docker image for the archivist, and plan to run that for sure. I’ll then tackle the diviner depending on the specs it needs to run.

Keep posting, I’ve found your posts very helpful!

1 Like
#11

@_ryan Thanks for nice comment on my posts, I really love working with this tech and its awesome to help and teach others. I have a Nexus 5 and Nexus 7, I am going to load the app on them right now and see if mine crash also. I am guessing on the Nexus 5 they definitely will crash due to the available amount of system memory, not sure if the Nexus 7 will be ok, it should. I’m not sure the available system memory for a G3, I used to love Moto, but haven’t had one since the Razer V3. I am guessing its either the Android Version or amount of sys mem that is causing it.

I have a tip for you, on the Play Store find and download an app called Fill RAM Full. Its a pretty cool app that basically accomplishes freezing as much possible system memory by lowering it to the lowest possible level, which causes your device to Force Stop all non-system and non-critical apps, freeing up largest amount of system memory possible.

Let me know if this helps! I am also really looking into building a archivist machine. I’m tracking it needs a pretty hardcore memory setup. Talking to some devs, you could make a freaking awesome one using the new NVME drives, if you could find big enough ones, maybe like 2TB and run like 3 or 4 of them with a machine with a badass 8th or 9th gen Intel i9 processor. But I am wondering if its not worth waiting a little while cause I am sure even better hardware will become available, and save you money in the long run by the time this goes full speed…but on the other hand being one of the first Archivists would also net you some great XYO…decisions decisions lol. Seriously though let me know if this app helps, cause then I can recommend it for more people if they have the same issue.

ReconCatLord :telescope::cat2::crown:

1 Like
#12

cool, I’ll do that. Right now the Nexus 5 is my daily phone but once I get a new one, I’ll be wiping it and putting just the XYO stuff on it, so that might help a bit. I like the Moto G line because they’re mostly fully functional and yet cheap… I can’t see spending a ton on a phone.

Regarding specs, I’m waiting for Pizzamind to post that. He commented in another post that he was working on it. Do you need some giant “mining” machine to run an archivist and/or diviner effectively? I’m waiting for him to say. I really don’t want to have to explain a $1000 monthly electric bill to my wife, so that would be a deal breaker for me. I’m also considering putting one or both in the cloud somewhere, again depending on what it takes to operate.

No matter what, this has been a blast so far… I’ve gone from mostly ignoring crypto at the start of 2019 to owning a few different coins now, comfortably moving assets between wallets, buying on a fiat-crypto exchange and crypto-crypto exchange. I needed a hobby and XYO looks to be it for the near future!

1 Like
#13

@_ryan As for the archivist machine, I think storage is the more important aspect of the machine. In other crypto mining machines the most important part was the GPUs(video cards). They are insanely expensive and suck power like crazy. The reason they needed so many huge GPUs with high performance is due to the number crunching that is required by Bitcoin/Proof of Work style mining. The more GPUs, the more you could hash per second. But in our case for an Archivist machine, I think its more about storage and quick access of stored data. So in theory they shouldn’t need anywhere need the power that other mining machines need. Especially with new SSD.M2, NVME style drives which don’t have any moving parts like old school platter drives have. So for an Archivist machine I think you would need a very large storage capacity, something atleast along the lines of 10TB to 60TB, a very fast internet connections(like a bonded connection), a decent server processor and pretty decent amount of RAM, like 32GB or 64GB or even 128GB. You would only need like a basic midrange single video card like a Nvidia GTX 1060. Wait a second…I just realized I remembered the site where they have machines available to be made for you, designed specifically for XYO Archivists, XYO Miners, and XYO Diviners. Let me link it here, the first group on the left is the Mining machines, the second group is the Archivists machines(Network Nodes). These are pretty pricey, you could build one on your own using their machine specs as a guide for a little cheaper, but this is something that pays for itself and you would want to go high end to future proof it. The Network Nodes are the ones you want to look at, the first group(Mining Rigs) are the ones that require lots of power, notice their specs they have like 4 to 8 GPUs. The Network Nodes for archivist only have a single GPU, but tons of Storage. So it shouldn’t murder your electric bill lol.

#14

@ReconCatLord I’m pretty sure the person behind that site is Pizzamind. I believe he was recently officially hired by XYO to help in that regard and should be putting up some specs and guides regarding running an archivist/diviner. You may be right about the storage needs, but it overall comes down to: is it cost effective? I don’t just mean profitable, I’m less concerned about that, I’m more interested in the tech and XYO as a hobby even if it costs me some money overall (within reason) as any hobby usually does.

Regarding storage itself, one elegant solution might be to run the archivist directly on a NAS unit (assuming meeting minimum specs to be effective) if you can load docker as you can with some units. Again, I don’t know if any home NAS solution is going to meet requirements, but since we don’t have an official specifications sheet out yet there’s no way to tell what is required. Hopefully that comes out soon.

For now I’m playing with getting an archivist up and running using docker and getting myself familiar with the tech.

2 Likes
#15

If you’re looking for home NAS you should look into a Drobo. I’ve been running one for years as a media storage. I’ll be getting another if I decide to do an Archivist. They are hot swappable and provide great redundancy.

1 Like
#16

@_ryan

You sound like you know more than I do and I am interested in setting up an Archivist both for personal curiosity interest in the project and also because it seems running and Archivist may be a potential income source ?

Have you gotten an Archivist running yet? I have attempted it with the instructions on XYO Devs but got stuck at the MySQL bit

https://developers.xyo.network/docs/en/archivist/

Can you help?

Below is the console log where I got stuck…

Starting MySQL service with credentials:

Username: admin

password: password

There was an error starting the MySQL service. Exit Code 125.

Error Message:docker: Error response from daemon: driver failed programming external connectivity on endpoint XyoDb (b9d10127cb4fed5be9d827ce08ea4c5fb3aa1a2c622ce460e37ee97ae71a732a): Error starting userland proxy: Bind for 0.0.0.0:3306 failed: port is already allocated.

error Command failed with exit code 1.

info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

MacBook-Pro-2:sdk-core-nodejs iainmthompson$

1 Like
#17

Hi ReconCatLord,
I’m using a Samsung Galaxy S6 and the new Network App just won’t start. It starts up and has the spinning circle for a few seconds, then it closes and I get a message that “XYO Network has stopped”. I have the option to restart or send feedback. If I restart the app again it tries to open and then crashes with “XYO Network keeps stopping” with the options to Close app or Send feedback.
I have tried force closing other apps before starting XYO, I have tried it without Bluetooth on and with, without Location services on and with. It never starts.
Jackoat

1 Like
#18

“not working for full potential yet.”

It’s not Fucking working at all!!

#19

@jackoat Hey there, OK so Galaxy S6 is error closing the Network App. This would be so much easier if I could just read your .logs on your phone, but since we don’t have that option lets try with first couple easy fixes see if it fixes it. So you said you tried closing/force closing apps but still got nothing, do you know what Android version you are using? If you go to your About section in your settings under the Software area you should see something that says Android Version and a number. Let me know what it is…also feel free to tap that little area seven times fast and enjoy a hidden flappy bird style game put in by developers…or it might be the Neko Cat collecting game, I forget what dev app is hidden originally in the S6, anyhow let me know we can go from there.

ReconCatLord :telescope::cat2::crown:

#20

Hi ReconCatLord,
My S6 has Android version 7.0

I have an older RCA tablet with Android 5.0 and the new app works on it.
Jackoat

1 Like