Archivist setup (for dummies)

Hi, I’m following the instructions to setup Archivist and got stuck at his step:

Bootstrap or manage your MySQL service

  yarn manage:db
Existing XyoDb container found. Status: Running
? What would you like to do with the existing XyoDb service? …
❯ Restart the existing database 
  Kill it and start a new one // SELECT THIS OPTION
  No action

When I run that command I get this message:

~/sdk-core-nodejs$ yarn manage:db
yarn run v1.15.2
$ node scripts/manage-xyo-db.js
No existing docker container found with name XyoDb
:heavy_check_mark: Enter a username for the sql database · admin
:heavy_check_mark: Enter a password for the sql database · password

Can someone please help me get unstuck? Do I need to go and manually create that XyoDb container and if so where/how? Thanks a bunch in advance and pardon if this is too novice. Just really want to get into the Matrix!

2 Likes

@vasduba I am in on way a expert on Node.js, but it looks like its just a location issue, I think docker should be creating that container but maybe its just not being found in the correct location, check your defaults and do some file exploring.

ReconCatLord :telescope::cat2::crown:

1 Like

I looked in this directory (sdk-core-nodejs) but couldn’t find it. Not sure where else to look for it.

1 Like

@vasduba I may be sounding like a fool as I said I am not to familiar with the defaults, but is there a Db or Projects directory, maybe something that was placed in a /usr area or within the node.js app area in /bin

No worries, I’m sure we are not the only ones. I serched everywhere but no luck so far. I think I need to create it so I’ll try to figure out how to do that. Thanks.

Did you set up a docker account? Did you select Kill it and start a new one? The user and password are your docker login info.

https://hub.docker.com/r/xyonetwork/sdk-archivist-nodejs/?utm_source=share&utm_medium=ios_app

Then see the instructions below. Perhaps this will help. If you have all the dependencies in place I believe this will work

Ah, that makes sense. No, I just installed Docker as per instructions but didn’t know to do that part (create an account). I’ll give that a go, thanks a bunch!

1 Like

You need to run as admin. So use ‘sudo’. You should see this:

ubuntu@instance-20190328-2216:~/sdk-core-nodejs$ sudo yarn manage:db
yarn run v1.15.2
$ node scripts/manage-xyo-db.js
No existing docker container found with name XyoDb
✔ Enter a username for the sql database · admin
✔ Enter a password for the sql database · password

Starting MySQL service with credentials:
Username: admin
password: password

Successfully started a MySQL service @ 127.0.0.1:3306
2 Likes

@silk35 Your the Man Silk! or Woman! Thank you for getting them this post, I came online to post something similar but yours was even more eloquent. Thanks!

ReconCatLord :telescope::cat2::crown:

2 Likes

Anytime. Ping me if you have any other questions. I have my Archivist up and running and will try and help if I can.

1 Like

@silk35 Do you have it running on just a Linux distro laptop or did you actually build a Archivist machine or use a Gaming Rig/Mining Rig? Would love to know your setup right now. I have a pretty decent Gaming Rig that I was thinking of turning into a Archivist machine, it has a decent overclocked CPU, Tri-SLI GPUs, SSD for operating system and DevOps programs, and all I would have to add is some really big storage drives to start out as an baseline Archivist machine.

ReconCatLord :telescope::cat2::crown:

1 Like

The Archivist is essentially a SQL database server so I have mine running on OCI managed instance. It’s a cloud instance. Once they come out with the official production version of the Archivist, I plan on setting up a physical server at home. Nothing fancy, just CPU and RAM. Don’t need GPU as it’s just storing data. You can set one up with a GPU if you plan on mining other cryptocurrency. But for mine, I’ll probably set one up with at least a quad core CPU, 16GB of RAM and 4TB of storage in Raid 10.

3 Likes

@silk35 Nice, ok great, that at least we are on the same page and going in the same direction. Yeah I’m tracking about the GPUs, they were already in there for gaming purposes, plus 1500W gold cert power supply and a Intel i7 6700K running stable at 4.9Ghz, liquid cooled, and 32GB Ram, OS drive is a Max IOPS Vertex 128gb, DevOps drive Max IOPS Vertex 256gb. All it would really need is like you said like 4 to 8TB in a RAID 10 (or RAID 0 weeee speed! lol) Maybe even spend the cash and go SSD NVME drives like two or three 2TB ones. I need to win the lotto lol.

ReconCatLord :telescope::cat2::crown:

2 Likes

Yea it gets expensive so I’m trying to go the least expensive route. LOL. I have an older gaming PC that I hardly use but I’m hesistant to convert that because I use it for photo editing as well. So I’m gonna look around for an older PC if possible.

1 Like

Thanks a lot to everyone who helped above. I used all those suggestions and got all the way to the last step but when I run it I get the error below…please guide me into the Matrix!

Do you want to start the node after configuration is complete? (Y/n) · true
info: 2019-04-03T03:25:02.068Z XyoPeerDiscoveryService: Adding bootstrap nodes
/ip4/127.0.0.1/tcp/11500
info: 2019-04-03T03:25:02.248Z XyoPeerDiscoveryService: Connected to Peer
info: 2019-04-03T03:25:02.269Z XyoPeerDiscoveryService: Discovery topic received for publicKey v-dub
info: 2019-04-03T03:25:02.271Z XyoPeerDiscoveryService: Discovered Peer
info: 2019-04-03T03:25:02.291Z XyoPeerDiscoveryService: Discovered Peer
Type “List” is missing a “__resolveType” resolver. Pass false into “resolverValidationOptions.requireResolversForResolveType” to disable this warning.
Uncaught exception. Will exit.

listen EADDRINUSE :::11001

Error: listen EADDRINUSE :::11001
at Object._errnoException (util.js:1022:11)
at _exceptionWithHostPort (util.js:1044:20)
at Server.setupListenHandle [as _listen2] (net.js:1367:14)
at listenInCluster (net.js:1408:12)
at Server.listen (net.js:1492:7)
at resolve (/home/v-dub/sdk-core-nodejs/node_modules/apollo-server/dist/index.js:73:28)
at new Promise ()
at ApolloServer. (/home/v-dub/sdk-core-nodejs/node_modules/apollo-server/dist/index.js:71:19)
at Generator.next ()
at /home/v-dub/sdk-core-nodejs/node_modules/apollo-server/dist/index.js:7:71
at new Promise ()
at __awaiter (/home/v-dub/sdk-core-nodejs/node_modules/apollo-server/dist/index.js:3:12)
at ApolloServer.listen (/home/v-dub/sdk-core-nodejs/node_modules/apollo-server/dist/index.js:54:16)
at XyoGraphQLServer. (/home/v-dub/sdk-core-nodejs/packages/graphql-server/dist/xyo-graphql-server.js:48:47)
at Generator.next ()
at /home/v-dub/sdk-core-nodejs/packages/graphql-server/dist/xyo-graphql-server.js:17:71
Uncaught exception. Will exit.

listen EADDRINUSE 0.0.0.0:11000

Error: listen EADDRINUSE 0.0.0.0:11000
at Object._errnoException (util.js:1022:11)
at _exceptionWithHostPort (util.js:1044:20)
at Server.setupListenHandle [as _listen2] (net.js:1367:14)
at listenInCluster (net.js:1408:12)
at doListen (net.js:1517:7)
at _combinedTickCallback (internal/process/next_tick.js:141:11)
at process._tickCallback (internal/process/next_tick.js:180:9)
info: 2019-04-03T03:25:03.320Z XyoP2PService: Topic received component-feature:request
info: 2019-04-03T03:25:03.321Z XyoP2PService: Message subscription with component-feature:request received
info: 2019-04-03T03:25:03.322Z XyoNodeNetwork: Received component-feature:request from v-dub
info: 2019-04-03T03:25:03.323Z XyoNodeLifeCycle: XyoNodeLifeCycle:stopped
info: 2019-04-03T03:25:03.330Z XyoGraphQLServer: Stopping Graphql server
info: 2019-04-03T03:25:03.331Z XyoNodeLifeCycle: XyoNodeLifeCycle:stopped
info: 2019-04-03T03:25:03.332Z XyoGraphQLServer: Stopping Graphql server
info: 2019-04-03T03:25:03.335Z XyoGraphQLServer: Stopped Graphql server
info: 2019-04-03T03:25:03.338Z XyoGraphQLServer: Stopped Graphql server
Exiting with exitCode 1

I tied to run it on a different port number and it worked but got another error…this is just kicking my ass and I may just wait till they simplify the setup (they wrote they were gonna do that) for those of us like me. The Matrix is not ready to welcome me in yet :relaxed:

Looks like another application may alread be listening to port 11001? Either that or the archivist is already running. Have you tried rebooting the instance and running the config again.

yep, I tried that but kept getting another error so I just kinda gave up for now. It says they will simplify the install process at some point so I’ll just wait.

Hi guys, I’mtrying to set up archivist following that guide https://developers.xyo.network/docs/en/archivist/
but i stuck on:

Go into the directory

cd sdk-core-nodejs

Install dependencies

yarn install

I’m using Ubuntu 18.04 and node, yarn and Lerna has been installed.
I’ve got following error:

Blockquote
/bin/sh: tsc: not found
error command failed with exit code 127.

I was searching for that cde but can’t find anything.

Anyone has a proper guidance of how to install archivist on ubuntu. The one on XYO is a bit mixed with the IOS.

Thanks